A Caravan forum. Caravan Banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Caravan Banter forum » Caravan, Motor Homes and Camping Newsgroups » UK Motor Caravans
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

UK Motor Caravans (uk.rec.motorcaravans)

Mororhome Hook-Up charging Problems



 
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old November 29th 03, 08:07 AM posted to uk.rec.caravanning,uk.rec.motorcaravans
SH
external usenet poster
 
Posts: 6
Default Mororhome Hook-Up charging Problems

We haven't had our McLouis motorhome very long but there appears to be a
problem when hooked up to the mains.
Initially the 240V light on the panel lights up & if you press the status
button the series of lights come up indicating that the leisure battery is
being charged.
This will continue for a while 10-15 mins then the light goes out. It is as
if the leisure battery is fully charged but the status panel indicates that
this is not so.
However, no matter how much the battery is discharged the light never comes
on again. It is only when I drive away from the pitch & on return hook-up
the same thing happens.
At all times, on hook-up, the fridge runs on 240V & the 240V outlet sockets
work.
I suspect that it may be a relay fault but I have checked the panel's and I
can't see any.
Can anybody give advice.

Steve


Ads
  #2 (permalink)  
Old November 29th 03, 02:23 PM posted to uk.rec.caravanning,uk.rec.motorcaravans
hugh
external usenet poster
 
Posts: 1,616
Default Mororhome Hook-Up charging Problems

In message , SH
writes
We haven't had our McLouis motorhome very long but there appears to be a
problem when hooked up to the mains.
Initially the 240V light on the panel lights up & if you press the status
button the series of lights come up indicating that the leisure battery is
being charged.
This will continue for a while 10-15 mins then the light goes out. It is as
if the leisure battery is fully charged but the status panel indicates that
this is not so.
However, no matter how much the battery is discharged the light never comes
on again. It is only when I drive away from the pitch & on return hook-up
the same thing happens.
At all times, on hook-up, the fridge runs on 240V & the 240V outlet sockets
work.
I suspect that it may be a relay fault but I have checked the panel's and I
can't see any.
Can anybody give advice.

Steve


There is a relay to change over from engine battery to leisure battery.
Perhaps you are actually charging the engine battery?
I had a problem with my leisure battery, found the + terminal was loose.
Could have shown similar symptoms to yours except I very rarely use
mains hook-up. Worth checking them though.
--
hugh
Reply to address is valid at the time of posting
  #3 (permalink)  
Old November 30th 03, 11:01 AM posted to uk.rec.caravanning,uk.rec.motorcaravans
Phil
external usenet poster
 
Posts: 113
Default Mororhome Hook-Up charging Problems

On Sat, 29 Nov 2003 15:23:50 +0000, hugh ] wrote:

Perhaps you are actually charging the engine battery?

In Hymer motor caravans, there is a trickle charge to the engine
battery whenever one is plugged into 240v - perhaps the McLouis is the
same.

Phil

  #4 (permalink)  
Old December 1st 03, 10:21 AM posted to uk.rec.caravanning,uk.rec.motorcaravans
David Miller
external usenet poster
 
Posts: 19
Default Mororhome Hook-Up charging Problems

Phil wrote:

In Hymer motor caravans, there is a trickle charge to the engine
battery whenever one is plugged into 240v


From when? My 1992 Mercedes Hymer S700 certainly doesn't do that (I
use a separate "maintenance" charger over the winter to keep the
engine battery OK).

Dave
  #5 (permalink)  
Old December 2nd 03, 08:16 AM posted to uk.rec.caravanning,uk.rec.motorcaravans
Phil
external usenet poster
 
Posts: 113
Default Mororhome Hook-Up charging Problems

On 1 Dec 2003 03:21:13 -0800, (David Miller)
wrote:

From when? My 1992 Mercedes Hymer S700 certainly doesn't do that

I cannot prove it does but it says so in the manual for my Mercedes
Starline B640.

Phil

  #6 (permalink)  
Old December 2nd 03, 09:15 AM posted to uk.rec.caravanning,uk.rec.motorcaravans
James Cheney
external usenet poster
 
Posts: 7
Default Mororhome Hook-Up charging Problems

"Phil" wrote
I cannot prove it does but it says so in the manual for my Mercedes
Starline B640.



My 1999 model does but the charging rate to the vehicle battery is designed
to be much lower than that to the leisure battery so there is not so obvious
a movement on the charging indicator.

Jim


 



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:59 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 3.0.0 RC6
Copyright 2004-2019 Caravan Banter.
The comments are property of their posters.