A Caravan forum. Caravan Banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Caravan Banter forum » Caravan, Motor Homes and Camping Newsgroups » UK Caravanning
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

UK Caravanning (uk.rec.caravanning) A forum for the discussion of caravanning undertaken by residents of the United Kingdom, whether in the UK or abroad. It encourages the interchange of views on the merits of models of caravan, makes of tow car, accessories, caravan sites, caravan clubs, and other related topics. The term caravan is to include trailer vans, motor caravans and trailer tents.

Carver Cascade 2 - No water pressure



 
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old May 9th 06, 10:34 AM posted to uk.rec.caravanning
Loz
external usenet poster
 
Posts: 10
Default Carver Cascade 2 - No water pressure

Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.

Ads
  #2 (permalink)  
Old May 9th 06, 10:38 AM posted to uk.rec.caravanning
David
external usenet poster
 
Posts: 1,622
Default Carver Cascade 2 - No water pressure


"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


On first operation we open the hot tap in the shower/wash basin this lets
air out and then we have no further problems.

--
Regards
David

Please reply to News Group


  #3 (permalink)  
Old May 9th 06, 10:38 AM posted to uk.rec.caravanning
David
external usenet poster
 
Posts: 1,622
Default Carver Cascade 2 - No water pressure


"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


On first operation we open the hot tap in the shower/wash basin this lets
air out and then we have no further problems.

--
Regards
David

Please reply to News Group


  #4 (permalink)  
Old May 9th 06, 10:38 AM posted to uk.rec.caravanning
David
external usenet poster
 
Posts: 1,622
Default Carver Cascade 2 - No water pressure


"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


On first operation we open the hot tap in the shower/wash basin this lets
air out and then we have no further problems.

--
Regards
David

Please reply to News Group


  #5 (permalink)  
Old May 9th 06, 10:53 AM posted to uk.rec.caravanning
BILL
external usenet poster
 
Posts: 128
Default Carver Cascade 2 - No water pressure

Hi Loz
Is this a submersible Pump ?
"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.



  #6 (permalink)  
Old May 9th 06, 10:53 AM posted to uk.rec.caravanning
BILL
external usenet poster
 
Posts: 128
Default Carver Cascade 2 - No water pressure

Hi Loz
Is this a submersible Pump ?
"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.



  #7 (permalink)  
Old May 9th 06, 10:53 AM posted to uk.rec.caravanning
BILL
external usenet poster
 
Posts: 128
Default Carver Cascade 2 - No water pressure

Hi Loz
Is this a submersible Pump ?
"Loz" wrote in message
oups.com...
Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.



  #8 (permalink)  
Old May 9th 06, 12:43 PM posted to uk.rec.caravanning
Roger Mills
external usenet poster
 
Posts: 418
Default Carver Cascade 2 - No water pressure

In an earlier contribution to this discussion,
Loz wrote:

Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


If it happens on both hot and cold, it has nothing to do with the water
heater - the water to the cold tap doesn't go via the heater!

Is it an internal pump, in one of the lockers? If so, check everything for
air-tight-ness. You could be sucking in air if the pump's filter assembly
isn't properly fitted, or if the pickup pipe in the aquaroll (or whatever)
isn't firmly fitted to the van's input pipe, or if any of the hose clips on
the suction side of the pump are loose.

There may also be a partial blockage in the pipes - or even duff tapwashers
which are providing a restriction. Does the problem happen with *all* taps -
kitchen sink, wash-basin, shower - or only with certain ones?

Finally, if you are running from 12v without mains hookup, make sure that
the battery is in tip-top condition. If the battery isn't very well, the
pump performance will be exceedingly sluggish - I've been there!
--
Cheers,
Roger
______
Email address maintained for newsgroup use only, and not regularly
monitored.. Messages sent to it may not be read for several weeks.
PLEASE REPLY TO NEWSGROUP!


  #9 (permalink)  
Old May 9th 06, 12:43 PM posted to uk.rec.caravanning
Roger Mills
external usenet poster
 
Posts: 418
Default Carver Cascade 2 - No water pressure

In an earlier contribution to this discussion,
Loz wrote:

Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


If it happens on both hot and cold, it has nothing to do with the water
heater - the water to the cold tap doesn't go via the heater!

Is it an internal pump, in one of the lockers? If so, check everything for
air-tight-ness. You could be sucking in air if the pump's filter assembly
isn't properly fitted, or if the pickup pipe in the aquaroll (or whatever)
isn't firmly fitted to the van's input pipe, or if any of the hose clips on
the suction side of the pump are loose.

There may also be a partial blockage in the pipes - or even duff tapwashers
which are providing a restriction. Does the problem happen with *all* taps -
kitchen sink, wash-basin, shower - or only with certain ones?

Finally, if you are running from 12v without mains hookup, make sure that
the battery is in tip-top condition. If the battery isn't very well, the
pump performance will be exceedingly sluggish - I've been there!
--
Cheers,
Roger
______
Email address maintained for newsgroup use only, and not regularly
monitored.. Messages sent to it may not be read for several weeks.
PLEASE REPLY TO NEWSGROUP!


  #10 (permalink)  
Old May 9th 06, 12:43 PM posted to uk.rec.caravanning
Roger Mills
external usenet poster
 
Posts: 418
Default Carver Cascade 2 - No water pressure

In an earlier contribution to this discussion,
Loz wrote:

Hi,

I was wondering if anyone could offer any advice.
I've not been caravaning for very long and am having problems with the
carver water pump in my caravan. It was working fine up until a few
weeks ago and now for some reason the water takes ages to run through
and the water pressure is greatly reduced.
After turning either the hot or cold tap on it takes about 30 seconds
for the water to start running through. You can hear the pump kick in
immediately though. There also seems to be a bit of a splutter before
the water runs and continues to splutter every now and again.
Could an airlock be causing this and if so, what can I do to clear it.
Are there any known issues with these? I have changed the water pump
assembly but this has not made any difference.
Any advice would be much appreciated.


If it happens on both hot and cold, it has nothing to do with the water
heater - the water to the cold tap doesn't go via the heater!

Is it an internal pump, in one of the lockers? If so, check everything for
air-tight-ness. You could be sucking in air if the pump's filter assembly
isn't properly fitted, or if the pickup pipe in the aquaroll (or whatever)
isn't firmly fitted to the van's input pipe, or if any of the hose clips on
the suction side of the pump are loose.

There may also be a partial blockage in the pipes - or even duff tapwashers
which are providing a restriction. Does the problem happen with *all* taps -
kitchen sink, wash-basin, shower - or only with certain ones?

Finally, if you are running from 12v without mains hookup, make sure that
the battery is in tip-top condition. If the battery isn't very well, the
pump performance will be exceedingly sluggish - I've been there!
--
Cheers,
Roger
______
Email address maintained for newsgroup use only, and not regularly
monitored.. Messages sent to it may not be read for several weeks.
PLEASE REPLY TO NEWSGROUP!


 



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:11 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 3.0.0 RC6
Copyright 2004-2019 Caravan Banter.
The comments are property of their posters.